How do I...?

DELETE /openapi/views/{viewId}/records/all returns 401 unauthorized

Hi,

I want to delete all records by using the API /openapi/views/{viewId}/records/all. It returns 401 unauthorized error.

1 vote
Vote
Sign in
(thinking…)
Sign in with: facebook google
Signed in as (Sign out)
You have left! (?) (thinking…)
Kapila Perera shared this idea  ·   ·  Flag idea as inappropriate…  ·  Admin →

2 comments

Sign in
(thinking…)
Sign in with: facebook google
Signed in as (Sign out)
Submitting...
  • Kapila Perera commented  ·   ·  Flag as inappropriate

    Hi Justin,

    Thanks for your reply.

    The title of the question is misleading, I'm actually send the correct url to the trackviaAPI as you mentioned bellow. The url is like this /openapi/views/123/records/all. still I get the same error.

  • Justin Mauldin commented  ·   ·  Flag as inappropriate

    Hi Kapila,

    Thank you for reaching out with your question.

    The reason you are getting these errors is because you need to drop the brackets in your syntax and then pull the actual value for the field your pulling.

    For example, rather than typing "{viewId}", you would type the ID number of the view. Let say for example the ViewID is 1234, your syntax would be written as "/openapi/views/1234/records/all", rather than "/openapi/views/{viewId}/records/all".

    Hope this helps!

    -Justin

Feedback and Knowledge Base