How do I...?

How to change the default form for each table?

How do change the default form for each table. I've tried in the roles section but no luck

2 votes
Vote
Sign in
(thinking…)
Sign in with: facebook google
Signed in as (Sign out)
You have left! (?) (thinking…)
Bob shared this idea  ·   ·  Flag idea as inappropriate…  ·  Admin →

8 comments

Sign in
(thinking…)
Sign in with: facebook google
Signed in as (Sign out)
Submitting...
  • Katie Ferraro commented  ·   ·  Flag as inappropriate

    Hello, I followed these instructions but it still does not seem to be working. Every time I click on a record id in a view, it takes me to the default form. I have selected all of the forms that I created as the forms for creating records, rather than the default forms.

  • Alex commented  ·   ·  Flag as inappropriate

    Hi Jason,

    On the role designer page, the second section on the page is called Views & Record Editing. This is the section where you can select specific views to assign to the role and which form you want to use when reading and editing records.

    You'll want to do this for each role in the app. You'll also want to include yourself in a role as the admin so you can use the custom forms over the TrackVia generated default forms.

    Regards,

    Alex

  • Jason commented  ·   ·  Flag as inappropriate

    I'm still having this problem. If I click on the id name in my table view, it takes me to the default view. This is the case for both an admin role, and a limited role, after modifying "Forms for creating records"

  • Alex commented  ·   ·  Flag as inappropriate

    Hi David,

    Hope all is well. The default form is always used for any user who isn't assigned to a role. You can use your custom forms as a super admin as well, you would just need to add yourself to an existing role that uses the forms or create an admin role for yourself that will use the custom forms when you want to add, edit, or delete records.

    Regards,

    Alex

  • David Boster commented  ·   ·  Flag as inappropriate

    I also ran into this issue. As Bob stated, it will work for limited users, but as a super admin it will always use the default form.

  • Bob commented  ·   ·  Flag as inappropriate

    Thanks Jake. I had done that without luck. Turns out it does not work if you have SuperAdmin status as I do. I set up a limited user and assigned it the new role and the default forms now work.

  • Jake Marwil commented  ·   ·  Flag as inappropriate

    Hi!

    Changing a default form is done through Roles. Once you have created a form and role, you can assign that form to a role by navigating to your app overview page, then clicking the "Edit" button for the specific role. There will be a section called "Forms for creating records". Just click the "Add/Remove" button and select the checkbox for the form you would like to assign to that role. Once selected, click "Done" and the click the "Save" button.

    Regards,

    Jake

Feedback and Knowledge Base