How do I...?

import dates or change a field's data type? All my imports - xlsx and csv - say date fields

1 vote
Vote
Sign in
(thinking…)
Sign in with: facebook google
Signed in as (Sign out)
You have left! (?) (thinking…)
Doyle Van Zandt shared this idea  ·   ·  Flag idea as inappropriate…  ·  Admin →

5 comments

Sign in
(thinking…)
Sign in with: facebook google
Signed in as (Sign out)
Submitting...
  • Jake Marwil commented  ·   ·  Flag as inappropriate

    Hi Dennis,

    A best practice for importing dates into TrackVia is to make sure they are in the
    (yyyy-mm-dd) format. An easy solution is to create an additional field in your Excel file and have it contain a formula (=TEXT(A1,"YYYY" & "-" & "MM" & "-" &"DD")) that reformats the source date field into the yyyy-mm-dd format as needed (Where A1 is your date column). Then make sure to copy/paste special this formula as values. When importing, ignore the original source data field and import the new correctly formatted field instead. Please let us know if you have any further questions.

    Regards,

    Jake

  • Anonymous commented  ·   ·  Flag as inappropriate

    My date fields in Excel (4-22-2014) were all listed as "Invalid" in the import. What is the valid format for TV?

  • DJ commented  ·   ·  Flag as inappropriate

    Doyle,

    We recently released a new import process that allows you to choose the field type to import. If our system identifies the best field type as a single line for the data in the spreadsheet, you can choose to change that to a date field type to resolve your problem.

  • Jennifer commented  ·   ·  Flag as inappropriate

    It is difficult to say why it is not importing properly without seeing the document. We recommend sending it over to us at support@trackvia.com so we can take a look. Most often, it has to do with the way the date is formatted in Excel. It sometimes stores values like 03/25/2005 as text, rather than as intrinsic dates and it can be hard to determine when this is happening. You can try confirming the field is stored as a date in the document and if you have any trouble, feel free to reach out to support. At this time we do not have the ability to convert text to a date type, however we are working on getting that functionality included in the near future.

  • Doyle Van Zandt commented  ·   ·  Flag as inappropriate

    Jeez. It truncated the rest of my question. All my imports identify date fields as "single line." How can I import dates or at least change field type.

Feedback and Knowledge Base